---
title: "4. / Command vs. @ Command"
description: "Using the slash and at commands to add or reference elements in the notebook entry."
url: https://help.labstep.com/en/articles/7869594-4-command-vs-command
collection: "Lesson 2: The Notebook"
updated: 2026-11-12
language: en
---

# 4. / Command vs. @ Command

Using the slash and at commands to add or reference elements in the notebook entry.

In this section, we will focus on how to use the / and @ command of the notebook entry.

**Tip**: If you don't want to open the slash command menu and simply type /, press the **ESC** key on your keyboard!

# 🌻 Using the Slash Command Menu

Typing / (slash) in the entry opens a menu with different options to add a variety of interactive elements. If you type / but don't want to use the slash command menu, press the escape key on your keyboard. All interactive elements can be named and renamed.

![](https://staticfiles.gleap.io/helpcenter/699dc51d2188da0fb351700e/20260224154115_1560.gif)

-   **Adding Steps** → To add a step to your protocol, click on the "_Step_" option in the slash command menu. You can **turn a numbered list into steps** by clicking on "_convert to Steps_".
    
-   [**Interactive Table**](https://help.labstep.com/en/articles/3388189-using-tables-on-labstep.md) → For your calculations, you can use the "_Interactive Table_" option. This feature is **spreadsheet-like**, **with embedded formulas**. You can import/export data in .xlsx and .csv formats. You can format it just like a spreadsheet like Excel or Google Sheets.
    
-   [**Inventory**](https://help.labstep.com/en/articles/3471459-using-the-inventory-module.md) → Add inventory fields by selecting the "_Inventory_" option in the slash command menu. **Connect your workflow to your inventory** and track what you use in your experiment. Specify the amount with the unit, and you can also add a custom unit.
    
    If you're working with samples, you can track that using the _Output_ feature. You can also toggle on **lineage tracking** to record the parent-child relationship of your sample. This also enables you to track where your sample originated from (including which workflow) and where it's been used. Remember to **specify the category** and **resource** when creating your protocol, it'll be easier when running it afterwards.
    
-   **Data** → Add data fields by selecting the "_Data_" option in the slash command menu. Track your **input** and **output** data. You can select whether the data field is required to be filled before completing your experiments. Select a **data type** from text, date, date and time, numeric, options, file/image, and sequence. Please note **output data fields** will be **cleared when repeating experiments**.
    
-   **Device** → Add devices to your protocol to **link device data**. When running the protocol, you can **fetch data from the device**. For more information on how to fetch data from a device, click [here](https://help.labstep.com/en/articles/5694792-setting-up-a-device-a-complete-guide.md).
    
-   **Timer** → Add timers to your protocol and name them. When running protocol, you can **start timers in real time**. It will tell you when the time runs out. You can also pause and restart them.
    
-   [**Conditions Table**](https://help.labstep.com/en/articles/6708126-using-variables-fields-and-multiple-conditions.md) → The Conditions Table gives you an **overview** of all the input variables that may be different for each condition and allows you to **easily record** the outputs associated with each. It enables you to run protocols and experiments using **multiple conditions** in parallel. Collect **structured data** in just a few clicks.
    
-   **File** → Add files from your **device**, the **folder watcher**, and **cloud storage** (Google Drive, OneDrive, dropbox, box). Please note that the upload **limit is 100MB**. For larger files, we recommend uploading them from your cloud storage.
    
-   **Image** → Similarly to files, add images from your device, the folder watcher, and cloud storage. The upload limit is also 100MB, like for files. Once uploaded, the image will be **inline** in the notebook entry. You can **annotate** and **edit** the image directly from the entry. Please note it is not available for now to resize the image in-app.
    
-   **Link** → Add a link to a text.
    
-   **Basic Table** → Basic tables are great if you don't need to do any calculations and just want a table for **presentation purposes**. To edit the table, click on one of the cells and click the table icon. From there, you'll be able to **insert/remove rows and columns**, **merge/split cells**, or delete the table.
    
-   **Code Snippet** → Labstep allows you to add code snippets to your entries and display formatted code. Supported programming languages include **Python**, **R**, **C**, **C++**, **C#**, **Matlab**, and **Sas**. With this feature, you can easily **add code to your entries** and ensure that it's formatted correctly for easy reading.
    
-   [**Chemistry**](https://help.labstep.com/en/articles/5739332-using-the-chemistry-tools-on-labstep.md) → If you're working with chemical reactions and molecular structures, Labstep makes it easy to **insert chemical reaction schemes** and **molecular structures** into your entries. You can also **fetch data from PubChem** and use the **stoichiometry table** for your calculations. Additionally, you can add chemicals produced directly to your inventory and link with other available items.
    
-   [**Jupyter Notebooks _(Premium Feature)_**](https://help.labstep.com/en/articles/6463715-getting-started-with-jupyter-notebooks.md) → We have **embedded Jupyter Notebooks** available in-app. With this feature, you can **insert executable code** for analysing data, using our open API, which is documented [here](https://labsteppy.readthedocs.io/en/latest/index.html). To activate this feature for your account, please get in touch with us at [info@labstep.com](mailto:info@labstep.com). This feature is ideal for users who need to perform complex data analysis and want a seamless way to integrate their code into their research entries.
    

# 🍄 Using the @ Command Menu

The "@ command" enables you to easily reference previously created elements.

![](https://staticfiles.gleap.io/helpcenter/699dc51d2188da0fb351700e/20260224154111_4776.gif)

The "@ command" can be used to reference various elements in the protocol/experiment or workspace altogether. Here are some of the options available:

-   **Inventory** → You can reference inventory fields used in the protocol/experiment or in the workspace.
    
-   **Data** → You can reference data fields used in the protocol/experiment or in the workspace.
    
-   **Device** → You can reference devices used in the protocol/experiment or in the workspace.
    
-   **Timer** → You can reference timers used in the protocol/experiment or in the workspace.
    
-   **Step** → You can reference steps used in the protocol/experiment or in the workspace.
    
-   **Protocol** → You can reference protocols used in the experiment or in the workspace.
    
-   **Table** → You can reference tables used in the protocol/experiment or in the workspace. This will display only interactive tables.
    

# ⭐️ Conclusion

Use the / command to elements to the notebook entry like data fields, steps, and tables. To reference elements in the experiment/protocol or in the same workspace, use the @ command.

* * *

# ☞ **_Knowledge Check:_**

-   The difference between / command and @ command
    
-   How to add different interactive elements such as a File/Image or an Inventory fields
    
-   How to open the Chemistry tools
    
-   What Data type you can add
    
-   How to reference a protocol used in a different experiment of the same workspace
    

* * *

This lesson is part of the _"_**_Labstep 101: Everything You Need to Know to Get Started_**_"_ course. View all lessons [here](https://help.labstep.com/en/collections/4001327-labstep-101-everything-you-need-to-know-to-get-started).
